Présentation de l'algorithme :

- On lance deux fois de suite un dé tétraédrique régulier dont les faces sont numérotées de 1 à 4.
- On s'intéresse à l'évènement A : "obtenir une somme égale à 5"
- Un nombre d'échantillons étant donné par l'utilisateur, le programme calcule et illustre le pourcentage d'échantillons
dont la fréquence de l'évènement A appartient à l'intervalle de fluctuation défini dans le programme de seconde.
- Ajout en rouge :échantillon de l'élève de fréquence 0.4 (40 pour une taille d'échantillon de 100)
- Ajout : diagramme en boite de la série

Tester l'algorithme :


(cliquer sur le bouton ci-dessus pour lancer ou relancer l'exécution de l'algorithme)
Remarque : si les messages "Algorithme lancé" et "Algorithme terminé" n'apparaissent pas au bout d'un moment dans la zone ci-dessous, c'est que l'algorithme contient une erreur.

Résultats :

Code de l'algorithme :
1     VARIABLES
2       nbre_echantillons EST_DU_TYPE NOMBRE
3       i EST_DU_TYPE NOMBRE
4       j EST_DU_TYPE NOMBRE
5       A EST_DU_TYPE NOMBRE
6       eff EST_DU_TYPE NOMBRE
7       freq EST_DU_TYPE LISTE
8       min_freq EST_DU_TYPE NOMBRE
9       max_freq EST_DU_TYPE NOMBRE
10      q1_freq EST_DU_TYPE NOMBRE
11      q3_freq EST_DU_TYPE NOMBRE
12      med_freq EST_DU_TYPE NOMBRE
13    DEBUT_ALGORITHME
14      LIRE nbre_echantillons
15      A PREND_LA_VALEUR 0
16      POUR j ALLANT_DE 1 A nbre_echantillons
17        DEBUT_POUR
18        eff PREND_LA_VALEUR 0
19        POUR i ALLANT_DE 1 A 100
20          DEBUT_POUR
21          SI (floor(4*random()+1)+floor(4*random()+1)==5) ALORS
22            DEBUT_SI
23            eff PREND_LA_VALEUR eff+1
24            FIN_SI
25          FIN_POUR
26        freq[j] PREND_LA_VALEUR eff/100
27        SI (freq[j]>=0.25-1/sqrt(100) et freq[j]<=0.25+1/sqrt(100)) ALORS
28          DEBUT_SI
29          A PREND_LA_VALEUR A+1
30          FIN_SI
31        TRACER_POINT (j,freq[j])
32        TRACER_SEGMENT (0,0.25+1/sqrt(100))->(nbre_echantillons,0.25+1/sqrt(100))
33        TRACER_SEGMENT (0,0.25-1/sqrt(100))->(nbre_echantillons,0.25-1/sqrt(100))
34        TRACER_POINT (nbre_echantillons/2,0.4)
35        FIN_POUR
36      A PREND_LA_VALEUR A*100/nbre_echantillons
37      AFFICHER "pourcentage dans l'intervalle de fluctuation : "
38      AFFICHER A
39      AFFICHER " % "
40      min_freq PREND_LA_VALEUR ALGOBOX_MINIMUM(freq,1,nbre_echantillons)
41      max_freq PREND_LA_VALEUR ALGOBOX_MAXIMUM(freq,1,nbre_echantillons)
42      q1_freq PREND_LA_VALEUR ALGOBOX_QUARTILE1_BIS(freq,1,nbre_echantillons)
43      q3_freq PREND_LA_VALEUR ALGOBOX_QUARTILE3_BIS(freq,1,nbre_echantillons)
44      med_freq PREND_LA_VALEUR ALGOBOX_MEDIANE(freq,1,nbre_echantillons)
45      AFFICHER "valeur minimale de la série :"
46      AFFICHER min_freq
47      AFFICHER "premier quartile (Q1) de la série :"
48      AFFICHER q1_freq
49      AFFICHER "troisième quartile (Q3) de la série :"
50      AFFICHER q3_freq
51      AFFICHER "valeur maximale de la série :"
52      AFFICHER max_freq
53      TRACER_SEGMENT (nbre_echantillons*11/10,max_freq)->(nbre_echantillons*11/10,q3_freq)
54      TRACER_SEGMENT (nbre_echantillons*11/10,min_freq)->(nbre_echantillons*11/10,q1_freq)
55      TRACER_SEGMENT (nbre_echantillons*10.5/10,q1_freq)->(nbre_echantillons*10.5/10,q3_freq)
56      TRACER_SEGMENT (nbre_echantillons*11.5/10,q3_freq)->(nbre_echantillons*11.5/10,q1_freq)
57      TRACER_SEGMENT (nbre_echantillons*10.5/10,q1_freq)->(nbre_echantillons*11.5/10,q1_freq)
58      TRACER_SEGMENT (nbre_echantillons*10.5/10,q3_freq)->(nbre_echantillons*11.5/10,q3_freq)
59      TRACER_SEGMENT (nbre_echantillons*10.5/10,med_freq)->(nbre_echantillons*11.5/10,med_freq)
60    FIN_ALGORITHME